Trying to install tidal on windows 10 machine


trying to install tidal on a windows 10 lenovo laptop and I get this error message:

Failed to build network- (which is required by tidal-1.4.9).
See the build log above for details.

This is the log:

C:\WINDOWS\system32>cabal install tidal
Resolving dependencies...
Build profile: -w ghc-8.10.1 -O1
In order, the following will be built (use -v for more details):

  • comonad-5.0.6 (lib:comonad) (requires build)
  • math-functions- (lib) (requires build)
  • network- (lib:network) (requires build)
  • bifunctors-5.5.7 (lib) (requires build)
  • mwc-random- (lib) (requires build)
  • hosc-0.17 (lib) (requires build)
  • tidal-1.4.9 (lib) (requires build)
    Starting comonad-5.0.6 (all, legacy fallback)
    Starting math-functions- (lib)
    Starting network- (all, legacy fallback)
    Building math-functions- (lib)
    Installing math-functions- (lib)
    Completed math-functions- (lib)
    Building comonad-5.0.6 (all, legacy fallback)
    Installing comonad-5.0.6 (all, legacy fallback)
    Completed comonad-5.0.6 (all, legacy fallback)

How should I proceed? Thanks for your support.

Hi @Moi, how did you install haskell/ghc, was it through choco or another route?

Hi @yaxu,

thanks. The error message in Atom is:

No configured ghc path

Ghci command: ghci Ghc-pkg command: ghc-pkg

Load BootTidal.hs from C:\Users\Moi Ici.atom\packages\tidalcycles\lib\BootTidal.hs


t>syntax: :script

the file at the end of the path

C:\Users\Moi Ici.atom\packages\tidalcycles\lib\BootTidal.hs

does exist. What can I do?


Hi @yaxu,

yes, through choco.

Ah, this is a bug in Haskell, which will hopefully be fixed in the next version. Basically it can't cope with spaces in file paths.

A workaround is creating a folder without spaces like c:\tidal, and copying the BootTidal.hs file there. Then in atom, go to edit > preferences > packages TidalCycles > settings and change the BootTidal.hs path to C:\tidal\BootTidal.hs there. That should fix that.

However maybe the Tidal library still isn't installed, due to this error with the network library..

1 Like

Hi @yaxu,

Thanks for explaining. I have created a c:\tidal folder and put the BootTidal.hs there. Also told Atom this boot path. After checking if the tidal library was installed I got this error message

cabal.exe: Failed to build network- (which is required by tidal-1.5.0).
See the build log above for details.

Resolving dependencies...
Build profile: -w ghc-8.10.1 -O1
In order, the following will be built (use -v for more details):

  • bifunctors-5.5.7 (lib) (requires build)
  • network- (lib:network) (requires build)
  • hosc-0.17 (lib) (requires build)
  • tidal-1.5.0 (lib) (requires download & build)
    Downloading tidal-1.5.0
    Starting bifunctors-5.5.7 (lib)
    Starting network- (all, legacy fallback)
    Downloaded tidal-1.5.0
    Building bifunctors-5.5.7 (lib)
    Installing bifunctors-5.5.7 (lib)
    Completed bifunctors-5.5.7 (lib)

Failed to build network- The failure occurred during the configure
Build log ( C:\Users\Moi
Configuring network-
cabal.exe: The package has a './configure' script. If you are on Windows, This
requires a Unix compatibility toolchain such as MinGW+MSYS or Cygwin. If you
are not on Windows, ensure that an 'sh' command is discoverable in your path.

What can I do now?

Thanks again,

Hi @yaxu,

do you have any ideas what I might try here?

Hi, sorry for missing this + thanks for the nudge. Does this help at all?

choco install haskell-dev msys2
cabal install tidal --lib

Thanks, @yaxu. Ran this code and it gives me a "cannot handle space in path" error again. Maybe I should rename the user name to ensure space-free filepaths in the future?

i know that for my (sorta recent) install on Windows 10, i had to use Cygwin to run all the inital command line stuff. not sure if anything's changed since then...

Hmm, interesting.. Maybe you could create a new user without a space, and see if it works there?

Or maybe cygwin can work as @kit-christopher suggests, but I don't know how to do that..

the Cygwin application worked like a charm. surprisingly very simple and not frustrating :slight_smile: just download the application and then do anything you'd normally do in the terminal/command prompt window.

Thanks @kit-christopher, that's precisely the point where my wits left me last time around. Where can download the app, please? I just tried and lots of weird things happend including opera starting by itself telling me to test a free vpn and a fast adblocker in my browser....So I'd be grateful for a safe link to cygwin installer for a windows 10 64 . Thanks*st

try this:

Hi @yaxu, created a new user, installed Atom, Supercollider, Haskell and Tidal. When running cabal install tidal it seems to install successfully. When attempting to play a sound in Atom I now receive the error message below. I don't think I've installed Haskell twice. What could I try now?
Thank you,

t>: error:
Could not find module `Sound.Tidal.Context'
It is not a module in the current program, or in any known package.

Variable not in scope: d1 :: t0 -> t

* Variable not in scope: sound :: [Char] -> t0
* Perhaps you meant `round' (imported from Prelude)

Hey @yaxu, problem solved!
Thanks for your support!

Hi @Moi I have the same problem with Sound.Tudal.Context How did you solve it?

I think it was the problem where haskell can't cope with folders with spaces in. The work around is to copy BootTidal.hs to e.g. c:\tidal and change the setting in the atom TidalCycles package to point there

Hi @nuelmyr, I did all the things I decribed above and double checked that haskell wasn't installed twice. In the end a simple reboot solved it.


1 Like