Ubuntu 16.04 (xenial) install issue

I'd like to get Tidal running on my linux laptop, running Ubuntu 16.04.6 LTS.

I installed cabal-install with apt-get, and tried to "cabal install tidal." The installation fails because of a problem with hosc-0.18.

I'm new to haskell and cabal. Can anyone suggest a workaround? Thanks.

cabal: Error: some packages failed to install:
hosc-0.18 failed during the building phase. The exception was:
ExitFailure 1
tidal-1.6.0 depends on hosc-0.18 which failed to install.

the buildlog says:

Configuring hosc-0.18...
Building hosc-0.18...
Preprocessing library hosc-0.18...
[ 1 of 18] Compiling Sound.OSC.Wait ( Sound/OSC/Wait.hs, dist/build/Sound/OSC/Wait.o )
[ 2 of 18] Compiling Sound.OSC.Coding.Convert ( Sound/OSC/Coding/Convert.hs, dist/build/Sound/OSC/Coding/Convert.o )
[ 3 of 18] Compiling Sound.OSC.Time ( Sound/OSC/Time.hs, dist/build/Sound/OSC/Time.o )
[ 4 of 18] Compiling Sound.OSC.Datum ( Sound/OSC/Datum.hs, dist/build/Sound/OSC/Datum.o )
[ 5 of 18] Compiling Sound.OSC.Packet ( Sound/OSC/Packet.hs, dist/build/Sound/OSC/Packet.o )
[ 6 of 18] Compiling Sound.OSC.Coding.Cast ( Sound/OSC/Coding/Cast.hs, dist/build/Sound/OSC/Coding/Cast.o )
[ 7 of 18] Compiling Sound.OSC.Coding.Byte ( Sound/OSC/Coding/Byte.hs, dist/build/Sound/OSC/Coding/Byte.o )

Not in scope: ‘Put.putInt16le’
Perhaps you meant ‘Put.putWord16le’ (imported from Data.Binary.Put)

I ran into this issue on a fresh install last night. I had to install tidal 1.5.2, which installs an older version of hosc. After that install succeeded I was able to upgrade to 1.6.0

cabal install tidal-1.5.2
1 Like

Thanks! That worked for me too.


cabal install tidal-1.5.2

I could upgrade to 1.6.0 with

cabal install tidal

awesome, thanks for posting this - I'm working on some installation automation using ansible, and ran into the same error on Mint 19.3

I may be able to add support all the way back to 16.04 now :slight_smile:

1 Like

Not sure what the hosc bug is, but maybe tidal can pin the older dependency until it’s resolved?

@yaxu https://github.com/tidalcycles/Tidal/commit/d6bdf993254847dca150b12c7d09b777c63e4d0a

Hi all,

We're looking at this problem and how to fix it here:

For now a workaround would be to install hosc-0.17 before tidal (effectively this is what installing a prior version of tidal does):

cabal install hosc-0.17 --lib
cabal install tidal --lib

hosc-0.18.1 is out now which hopefully solves this issue


It works, thanks!

1 Like

Thanks @yaxu and @lxyxpx!

The mysterious @lxyxpx was me accidentally using a test account :slight_smile:

You could've had some fun with that .. ah well :wink:

1 Like