Uncaught Error: Cannot call write after a stream was destroyed

Tidal seems to be booting correctly, but every time I try to evaluate anything, it spits out an error that says "Cannot call write after a stream was destroyed". I'm very new to this so apologies if I'm missing something obvious :stuck_out_tongue: also I'm running on windows 10

Hmm that's strange, as it looks like it's started fine.. maybe @ndr_brt has an idea?

Hi, could you please paste here the stack trace? It will shown if you click on the + Show Stack Trace

@ndr_brt sure, here's the stack trace

Error [ERR_STREAM_DESTROYED] [ERR_STREAM_DESTROYED]: Cannot call write after a stream was destroyed
at doWrite (_stream_writable.js:431:19)
at writeOrBuffer (_stream_writable.js:419:5)
at Socket.Writable.write (_stream_writable.js:309:11)
at Process.writeLine (file:///C:/Users/avery/.atom/packages/tidalcycles/lib/process.js:53:24)
at REPL.tidalSendLine (file:///C:/Users/avery/.atom/packages/tidalcycles/lib/repl.js:78:15)
at REPL.tidalSendExpression (file:///C:/Users/avery/.atom/packages/tidalcycles/lib/repl.js:69:10)
at file:///C:/Users/avery/.atom/packages/tidalcycles/lib/repl.js:95:14
at Array.forEach ()
at REPL._eval (file:///C:/Users/avery/.atom/packages/tidalcycles/lib/repl.js:87:8)
at HTMLElement.tidalcyclesEval (file:///C:/Users/avery/.atom/packages/tidalcycles/lib/tidalcycles.js:71:45)
at CommandRegistry.handleCommandEvent (C:\Users\avery\AppData\Local\atom\app-1.60.0\resources\app\static<embedded>:11:352694)
at KeymapManager.dispatchCommandEvent (C:\Users\avery\AppData\Local\atom\app-1.60.0\resources\app\static<embedded>:11:1228469)
at KeymapManager.handleKeyboardEvent (C:\Users\avery\AppData\Local\atom\app-1.60.0\resources\app\static<embedded>:11:1224603)
at WindowEventHandler.handleDocumentKeyEvent (C:\Users\avery\AppData\Local\atom\app-1.60.0\resources\app\static<embedded>:11:286682)

So you aren't able to evaluate anything? Neither with a fresh atom reboot? In the console I read a Reboot atom-tidalcycles plugin, could you try without rebooting the plugin but the whole editor? same error?

Trying to evaluate anything causes that error. Same error after rebooting the whole editor too.

Operating system? Atom version (I guess 1.60 looking at the stack trace)? Plugin version?

That leaving GHCI log entry makes me :thinking:

Got it, this is no an atom plugin issue, you are on Windows, and to use tidal 1.9.2 you'd need ghci 9.4.2.
I don't remember where this is reported (can't find it on the documentation), but it was because the new Link based scheduler.
Please refer to: TidalCycles version 1.9.0

Got it working, thanks for the help!

1 Like