VSCode extension: Sound browser not loading the sample packs for me?

Hi all,
Not sure if anyone can help me, I’m trying to make use of the sound browser in VSCode to load the sample packs from the Cycle Zero course - I’ve added the path to the following section of settings.json and restarted vscode:

"tidalcycles.sounds.paths": [
    "/home/bernie/.local/share/SuperCollider/downloaded-quarks/Dirt-Samples/"
    , "/home/bernie/Music/Samples/Tidal Club/samples-extra/"
]

But it’s still not showing in the browser - can anyone let me know what I’m doing wrong? (PS the path is def right)

I’ve not really used VSCode, but maybe the space in the path is confusing it? It might be worth renaming that folder to TidalClub to see if it makes a difference.

Good pickup @yaxu, you gave me a shock - I was actually going against my normal folder naming processes there :wink:

The quotes around the path handle the spaces though, so unfortunately that hasn't changed anything :frowning:

Hm OK, worth making an issue here I think https://github.com/tidalcycles/vscode-tidalcycles/issues

Yeah I'm also using the VSCode plugin and experienced the same problem (sound browser not working).
I'm quite sure the path I've got is correct too but still doesn't work. Maybe a permission issue or something like that? :thinking:

What OS are y’all using?

Bryan

Yep will do - I’ll have a look tonight

Linux (ubuntu studio)

No permission issue, same user on all files (and they are readable by all anyway, which is all the extension should require)

I’m on Windows 10…

I've logged a bug, I'm actually thinking it's probably a pretty simple bug to solve - will try and take a look this week if I get time:

2 Likes

If you’re on Windows 10, you need to include the drive letter, etc. So for me, my home directory is:

c:\Users\bgreen4

…and you also need to make sure to double the backslashes in order to escape them:

c:\\Users\\bgreen4

1 Like

That’s weird, you have to escape them even though the line is quoted?

[edit] ok something else weird, without doing anything except leaving my laptop overnight the samples-extra folder is now appearing in the sound browser!?

I did restart vscode several times, also reloaded the extensions, nothing worked yesterday -

Thanks! Yeah you are totally right. Turns out it was actually something else, but reading your message reminded me!

I said I was on Windows 10 but actually I set up things to use the Windows Subsystem for Linux (WSL). Long story short: I was setting the path in VSCode as a Windows path (as in your example c:\\Users\\bgreen4) but actually the correct one would be /mnt/c/Users/bgreen4 because the tidal plugin is running as "remote" inside the WSL and the usual windows drives (c:, d: etc.) are mounted in /mnt.

(for the records, I used to run tidal on windows 10 in the past and works totally fine.. this time I was already playing around with WSL and wanted to give it a go. it works fine also, but probably not worth the extra setup and definitely not needed since there are no problems running tidal native on windows)

3 Likes

Glad to hear you got it sorted - I added a bunch of extra sample packs yesterday, and they all loaded with a vscode restart... not sure what was going on previously.

Kindohm has closed that ticket - so no answers here I'm afraid for any future people looking for help :wink:

[edit] ...unless of course you're running WSL and having some path formatting confusion of course!

1 Like