Waiting for Superdirt

I haven't used TidalCycles in a while, and I tried to run it an had a bunch of problems, so after a lot of attempts at getting it to work I deleted tidal/cabal/ghc/atom extension and re-installed everything. I'm now able to run TidalCycles fine, but it's unable to connect to superdirt, even though superdirt is running (SuperDirt: listening to Tidal on port 57120). My BootTidal file lists this same port to communicate to SuperDirt on. I can't figure out what's up.

Behavior:
Open Atom, run a line of a .tidal file:

Choose ghcup default path: /Users/natewilliams/.ghcup/bin
Ghci command: /Users/natewilliams/.ghcup/bin/ghci
Ghc-pkg command: /Users/natewilliams/.ghcup/bin/ghc-pkg
Load BootTidal.hs from /Users/natewilliams/.atom/packages/tidalcycles/lib/BootTidal.hs
t> 
Loaded package environment from /Users/natewilliams/.ghc/x86_64-darwin-8.10.4/environments/default
t> 
t> [TidalCycles version 1.7.1]
Installed in /Users/natewilliams/.cabal/store/ghc-8.10.4/tdl-1.7.1-857808f6/share
Listening for external controls on 127.0.0.1:6010
t>  [TidalCycles v1.7.1]
 
t> Waiting for SuperDirt..
t> Waiting for SuperDirt..
t> Waiting for SuperDirt..

The Waiting for SuperDirt.. messages continue forever.

Environment info:

GHCi, version 8.10.4: https://www.haskell.org/ghc/  :? for help
Loaded package environment from /Users/natewilliams/.ghc/x86_64-darwin-8.10.4/environments/default

Prelude> import Sound.Tidal.Context
Prelude Sound.Tidal.Context> tidal_version
"1.7.1"

Supercollider: SuperCollider 3.10.3
on updating SuperDirt, Quark 'SuperDirt' updated to version: nil tag: nil refspec: 2f31f42be32113d0add2a6f8e573e7ee4ca2765d -> Quarks

Could I please have some help with this? Thanks a lot!

Try to update superdirt to 1.7.2 evaluating this code in supercollider:

Quarks.checkForUpdates({Quarks.install("SuperDirt", "v1.7.2"); thisProcess.recompile()})
1 Like

Thanks, this helped with this issue.
SuperCollider was still not producing any sound, so I decided to install the newest version. Now the IDE hangs whenever I try to open it (on macos). I've tried deleting all supercollider files, re-installing the old version, restarting, etc, but I can't get supercollider to start. Sclang works from the command line though. Any idea what's going on??

Actually, I got it to work with the sclang interpreter, without using the SuperCollider ide. Thanks for the help :slight_smile:

Hi, I'm having the same problem.

Pretty sure i've installed the new version of Tidal and i've run the code in SuperCollider before booting up. I open Atom and boot Tidal and i get the following:

Custom ghci path configured: ~/.ghcup/bin/ghci

Ghci command: /Users/thomasharrisson/.ghcup/bin/ghci Ghc-pkg command: /Users/thomasharrisson/.ghcup/bin/ghc-pkg

Start atom-tidalcycles plugin

Load BootTidal.hs from /Users/thomasharrisson/.cabal/share/x86_64-osx-ghc-8.10.4/tidal-1.7.1/BootTidal.hs

t>

t>

t> [TidalCycles version 1.7.1] Installed in /Users/thomasharrisson/.cabal/share/x86_64-osx-ghc-8.10.4/tidal-1.7.1 Listening for external controls on 127.0.0.1:6010

t> [TidalCycles v1.7.1]

t> Waiting for SuperDirt..

t> Waiting for SuperDirt..

Hi @tomh, did you try this in supercollider?

Yep, pretty sure i tried that before. When I run that I get this in SuperCollider:

Installing SuperDirt
WARNING: SuperDirt has uncommited changes, cannot checkout v1.7.2
Installing Vowel
Vowel installed
Installing Dirt-Samples
Dirt-Samples installed
SuperDirt installed
compiling class library...
Found 836 primitives.
Compiling directory '/Applications/SuperCollider.app/Contents/Resources/SCClassLibrary'
Compiling directory '/Users/thomasharrisson/Library/Application Support/SuperCollider/Extensions'
Compiling directory '/Users/thomasharrisson/Library/Application Support/SuperCollider/downloaded-quarks/Vowel'
Compiling directory '/Users/thomasharrisson/Library/Application Support/SuperCollider/downloaded-quarks/Dirt-Samples'
Compiling directory '/Users/thomasharrisson/Library/Application Support/SuperCollider/downloaded-quarks/SuperDirt'
Compiling directory '/Users/thomasharrisson/Library/Application Support/SuperCollider/downloaded-quarks/BatLib'
Compiling directory '/Users/thomasharrisson/Library/Application Support/SuperCollider/downloaded-quarks/FoxDot'
numentries = 1266547 / 19567716 = 0.065
5803 method selectors, 3372 classes
method table size 20792984 bytes, big table size 156541728
Number of Symbols 14908
Byte Code Size 441592
compiled 562 files in 0.53 seconds
compile done
localhost : setting clientID to 0.
internal : setting clientID to 0.
Class tree inited in 0.03 seconds

*** Welcome to SuperCollider 3.10.3. *** For help press Cmd-D.

Not sure what the WARNING is about or if it's significant?

I actually also had this problem when I did this. To get around it, I completely deleted the superDirt directory and re-installed it.

I think another way to get around this would be to navigate to the SuperDirt directory and check out the v1.7.2 tag on git, if you have/know git.

Thanks, @nate_birds I saw your previous comment. I'm pretty useless at this. How do I delete and reinstall SuperDirt?

OK, I'm stuck. I've tried completely deleting and reinstalling SuperCollider. Ditto I think with Cabal/GCH. Pretty sure both version are up to date and i'm still having the same problem.

i'm still using Mac OsCatalina 10.15. Don't know if that's relevent?

I'm by no means an expert here, but I think you can uninstall SuperDirt by deleting everything in
/Users/YOUR_USERNAME/Library/Application Support/SuperCollider/downloaded-quarks/SuperDirt.

Does it help to delete this folder and then reinstall the SuperDirt quark?

Yep, i've tried deleting and reinstalling literally everything now (even Atom). No dice. Anyone out there?

When you run this:

Do you still get this warning like WARNING: SuperDirt has uncommited changes, cannot checkout v1.7.2 ?

Also can you share the output of running this in supercollider please:

Quarks.installed

Based on the above it seems upgrading a supercollider quark is error prone. I'm going to install the latest supercollider and see if I can suggest some improvements for the devs..

Yep, it's still coming up with the Warning.

I get the following output for Quarks.installed:

-> [ Quark: Vowel[472222fc51028abf749f56d89d21bd2fce434d17], Quark: Dirt-Samples[aa930db8a1bf71d7170ef2a49a39c33fc84400e6], Quark: BatLib[1.0], Quark: FoxDot[520198049b36c7d42efbea17000b91f151c88c5f], Quark: SuperDirt[8f29e44bb20c804b9db4013097916af908377c87] ]

The warning is a badly concealed error. It means there is something in the SuperDirt folder that has been manually changed, so it doesn't want to update to the new version.

I think this should fix it:

cd ~/Library/Application\ Support/SuperCollider/downloaded-quarks/SuperDirt
git stash
git pull https://github.com/musikinformatik/superdirt.git
git checkout v1.7.2

Thanks, Alex. pasted the above in Terminal. It did something, but I tried booting from Atom again and it still just says "Waiting for Superdirt" :sweat:

Can you post the whole supercollider console output?

and also the output when you run those git commands

This output is now different from the first time I ran it (Can't remember what was different but i think it gave me a list of files)

Saved working directory and index state WIP on (no branch): 7abb62e Merge pull request #228 from musikinformatik/develop
From https://github.com/musikinformatik/superdirt

  • branch HEAD -> FETCH_HEAD
    hint: Waiting for your editor to close the file...

Merge https://github.com/musikinformatik/superdirt into HEAD

Please enter a commit message to explain why this merge is necessary,

especially if it merges an updated upstream into a topic branch.

Lines starting with '#' will be ignored, and an empty message aborts

the commit.

~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
<ion Support/SuperCollider/downloaded-quarks/SuperDirt/.git/MERGE_MSG" 6L, 287C