Windows 10 issues when Booting TidalCycles

I'm having issues booting tidal from Atom on windows 10. Initially, I tried the Windows 'easy' install; it didn't work, so I uninstalled chocolatey et al, and tried again with the manual process, and it worked(!) until I rebooted. Now I get what I think is the same error as I was experiencing with the previous install when I attempt to boot tidal from atom. It produces a 't>The directory name is invalid.' and the attached stack trace. Is there a more verbose log somewhere that I could use to debug this issue? Thanks!

[Enter steps to reproduce:]

  1. Start Atom
  2. Packages -> TidalCycles -> Boot TidalCycles

Atom: 1.46.0 x64
Electron: 4.2.7
OS: Microsoft Windows 10 Pro N
Thrown From: tidalcycles package 3.10.0

Stack Trace

Uncaught Error: write EPIPE

At events.js:167

Error: write EPIPE
    at afterWriteDispatched (internal/stream_base_commons.js:78:25)
    at writeGeneric (internal/stream_base_commons.js:73:3)
    at Socket._writeGeneric (net.js:713:5)
    at Socket._write (net.js:725:8)
    at doWrite (_stream_writable.js:410:12)
    at writeOrBuffer (_stream_writable.js:394:5)
    at Socket.Writable.write (_stream_writable.js:294:11)
    at Ghci.writeLine (/packages/tidalcycles/lib/ghci.js:20:24)
    at REPL.tidalSendLine (/packages/tidalcycles/lib/repl.js:138:15)
    at REPL.initTidal (/packages/tidalcycles/lib/repl.js:125:10)
    at REPL.start (/packages/tidalcycles/lib/repl.js:60:10)
    at HTMLElement.tidalcyclesBoot (/packages/tidalcycles/lib/repl.js:27:16)
    at CommandRegistry.handleCommandEvent (~/AppData/Local/atom/app-1.46.0/resources/app/static/<embedded>:11:349538)
    at CommandRegistry.dispatch (~/AppData/Local/atom/app-1.46.0/resources/app/static/<embedded>:11:348013)
    at AtomEnvironment.dispatchApplicationMenuCommand (~/AppData/Local/atom/app-1.46.0/resources/app/static/<embedded>:1:752272)
    at EventEmitter.t (~/AppData/Local/atom/app-1.46.0/resources/app/static/<embedded>:1:760195)
    at EventEmitter.emit (events.js:182:13)


Non-Core Packages

tidalcycles 3.10.0 

I think that's atom failling to find the haskell 'ghci' command. Are you able to run ghci from a command prompt? Maybe haskell didn't install properly, or maybe it did, but the atom tidalcycles plugin needs configuring to point to the correct location of ghci.

ghci appears to be on my path, I can run it from cmd just fine, although I did need to explicitly specify the path to gchi in the Tidal package settings. If I remove this setting, I get an error like:

No configured ghc path

Ghci command: ghci 
Ghc-pkg command: ghc-pkg

Update: In the course of removing the path and restarting Atom to generate the above error, then restoring that setting to its original state, I seem to have fixed the problem? Good news, I guess!