Windows installation ghc problem

Hi! Thanks in advance!

I'm on Windows 10

Tried installing it normally, this error appears when trying to boot up tidal on the atom side:

t> *** Exception: loadArchive "C:\\ghcup\\ghc\\9.2.4\\mingw\\lib\\gcc\\x86_64-w64-mingw32\\10.2.0\\libstdc++.dll.a": failed

I read that maybe my ghc version was not 9.4.2 or higher, so I upgraded ghc, then did 'cabal update' and 'cabal install tidal' just in case (I had the latest version already)

the same error appears

then i tried reinstalling tidal via --reinstall, no change

what should I do? should i delete everything and try again from scratch? I'm not sure how to do that :sweat_smile:

I just realized that the path is still refering to an older ghc version, maybe that's the problem?

Indeed sounds like it! It can be a good idea to delete the cabal directory after upgrading GHC in case you face issues.

For me, ghcup is the best way to manage GHC installations on Windows.

I tried that, didn't work either :frowning:

I think I want to try a clean install, but i don't know how to uninstall haskell and tidal on windows, the documentation is empty on that regard :confused: could someone guide me?

I can not give a straight answer - it can be complicated to fully get rid of everything. Best is to search for 'uninstall haskell windows' and filter for latest year.

See if you can manage to uninstall Haskell and cabal. Delete the cabal library folder. Make sure your PATH no longer contains anything Haskell related. Then start over using ghcup.

All my best wishes of luck and fortune in this endeavour!

1 Like