Error Atom

I got an error like this. I'm a beginner.

t>
: error:
Could not find module ‘Sound.Tidal.Context’
It is not a module in the current program, or in any known package.

Variable not in scope: d1 :: t0 -> t

• Variable not in scope: sound :: t1 -> t0
• Perhaps you meant ‘round’ (imported from Prelude)

I solved, thank you.

Hi!
I get the same error.
How did you solve it?

Thank you!

Hi, diegonoguerab
Yes, it has been resolved.
The cause is that tidal--lib is not installed properly.
I posted the solution in the article. But It's Japanese only yet. Please use Google Translate and try it.

Hi, Barbe
Thank you for your answer.
I tried to install homebrew by pasting the code in terminal but it seems that it doesn't worked out (Im really new to this...)
This is what I got;

diegonogueraberger@MacBook-Pro-de-diego ~ % /bin/bash -c "$(curl -fsSL

https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"

curl: no URL specified!

curl: try 'curl --help' or 'curl --manual' for more information

zsh: no such file or directory: https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh

Hi, diegonoguerab
Have you solved it yet?
If you haven't solved it yet, copy and paste the code below and try again.

and,
Homebrew site is it // The Missing Package Manager for macOS (or Linux) — Homebrew

/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"

Then run the code below in order in your terminal.
GHC is 8.10, llvm is version 12, and you can pass the path.

Tidalbootstrap

curl https://raw.githubusercontent.com/tidalcycles/tidal-bootstrap/master/tidal-bootstrap.command -sSf | sh

llvm version 12

brew install llvm@12

GHC 8.10.7 and opt and llc of pass

OPT=/opt/local/bin/opt-mp-12 LLC=/opt/local/bin/llc-mp-12 ghcup install ghc 8.10.7 --force

ghc 8.10.7 set

ghcup set ghc 8.10.7

Tidal install

cabal update
cabal install tidal --lib

and
The terminal will show that you through the path yourself after installing howbrew.
Take the pass to the location indicated by the terminal.

example--
– Add Homebrew to your PATH in /Volumes/home/home_barbe/.zprofile:
echo ‘eval $(/opt/homebrew/bin/brew shellenv)’ >> /Volumes/home/home_barbe/.zprofile
eval $(/opt/homebrew/bin/brew shellenv)

% echo 'eval $(/opt/homebrew/bin/brew shellenv)' >> /Volumes/home/home_barbe/.zprofile
% source ~/.zprofile

Check if the installation is successful.

% brew -v

Hello Barbe!
I really appreciate your help and patience. I followed step by step what you indicated in your answer. I installed each of the programs, but still Tidal shows me the same error. In TERMINAL I could see that Tidal couldn't figure out the llvm version.
Thanks again !
Its been days trying to install Tidal!

This is the error I get from ATOM

Blockquote. t>
Variable not in scope: d1 :: t0 -> t

Maybe I think the tidal library didn't install properly.

Please try re install tidal library.

cabal update

and

cabal install tidal --lib

Did you get any errors when installing?

I tried what you just wrote and I got this error;

<no location info>: error:
Warning: Couldn't figure out LLVM version!
Make sure you have installed LLVM between [9 and 13)

<no location info>: error:
Warning: Couldn't figure out LLVM version!
Make sure you have installed LLVM between [9 and 13)
ghc: could not execute: opt
)
Failed to build exe:hsc2hs from hsc2hs-0.68.8 (which is required by exe:tidal
from tidal-1.7.10). See the build log above for details.
Failed to build indexed-traversable-0.1.2 (which is required by exe:tidal from
tidal-1.7.10). See the build log above for details.
Failed to build primitive-0.7.3.0 (which is required by exe:tidal from
tidal-1.7.10). See the build log above for details.
Failed to build splitmix-0.1.0.4 (which is required by exe:tidal from
tidal-1.7.10). See the build log above for details.
Failed to build tagged-0.8.6.1 (which is required by exe:tidal from
tidal-1.7.10). See the build log above for details.

I was the error too. but, after installing llvm 12 and GHC 8.10.7 (and path), I set ghcap and it succeeded.

Is GHCup Arm version?
You can check it with this code.

file ~/.ghcup/bin/ghcup

If it is displayed in the terminal as executable arm64, It is OK .

and then
Install llvm version 12 with Homebrew.

brew install llvm@12

Install GHC 8.10.7 through the path to llvm12 that you just installed.
(The LLVM opt and llc commands are required to generate the executable file.)
I'm sorry. The location of llvm @ 12 was different...

OPT=/opt/homebrew/opt/llvm@12/bin/opt LLC=/opt/homebrew/opt/llvm@12/bin/llc ghcup install ghc 8.10.7 --force

Reinstalling will reset the default GHC settings, so execute the following command in the terminal.

ghcup set ghc 8.10.7

After completing the above execution without any error, please try installing the Tidal library again with cabal.

IT WORKED!!!! Hearing that first kick never felt so nice. THANK YOU for all your help during these days! I deeply appreciate it!!!!

Good, have fun!!

Hi, diegonoguerab
Please check this post.

That's great. It will help many people. I have just read it.
I will be lookin in this forum if someone needs help with their M1. I can send them your article :slight_smile:
Thanks again for your work.

Hi this isnt working for me. I get to posting this line in terminal and get this back...

zsh: command not found: ghcup
seancarroll@SEANs-MacBook-Pro ~ %

...and when booting tidal I still get the t>
: error:
Could not find module ‘Sound.Tidal.Context’
It is not a module in the current program, or in any known package.

Any help would be greatly appreciated.