Issue with tilde

Hi, something weird is going on with ~.
Whenever I've written a tilde I can't edit the rest of the code without it overwriting the tilde.

Not sure how to explain this without video but it's as if the tilde is forever highlighted after it's created. Whatever or wherever I type it snaps to were the tilde was at and overwrites it. The only fix is to restart Atom but as soon as I type in a new one the same thing happens.

Bug or feature?

That's really strange.. Is this something that's always happened or a recent thing?

Recent thing. And only in one of my .tidal files as far as I can tell. When it started happening it was like 50/50 if it would behave normally or go bonkers but now it's every time I type it.

Maybe this is more of an Atom issue?

I could send you a screen recording and the .tidal file if that would help.

That's strange. If you rename the file or copy and paste the contents into a new one does it still happen? Maybe atom got into a funny mode with that file.

Jup still acting up. Now it's happening in all files. I'll try reinstalling Atom. Brb

Reinstalled atom and it's still being weird. Didn't do a full sweep though, it seems laborious. Should I bother?

Could you share a quick screenshot? and check the tidalcycles atom package is up to date and you haven't got any other plugins installed that might be conflicting with it?

screenshot won't tell you much but I recorded my screen.

Here's the clip

No other plugins and the package is up to date.

I'm using ATOM and tilde has always (dis)functioned like that and I just assumed it's a "feature" and not a bug. Happy if the behaviour could be changed.

Aha oh well, it is manageable. I just realized that If I type something before clicking away to somewhere else it works as expected. but it is annoying though.

Ah good to know it's not just one person. @ndr_brt any ideas?

That's weird! I tried to replicate the behaviour but without luck...
It happens only after a mouse click?
Operating System?
Can you try to disable autocomplete?

Jup only after mouse click. If I type ~ and then click away it snaps back, overwriting the tilde. But if I type ~ and some other symbol right after everything is fine.

Autocomplete is disabled and I run macOS 10.13.6.

This is not a huge issue, I can work around it so no stress. Just mildly inconvenient really.

Yes, but I'm a curious person and I want to know why :smiley:
You need a shortcut to digit a tilde or is a direct key? Because maybe that shortcut is bound to an atom command (On italian keyboard it's Alt gr+ì)

It's a shortcut: Alt+¨
I'm on a Swedish keyboard if that's any help. suspect is that there's an atom command bound to that shortcut...try to look at the configured keybind.
@pyrrhic what's your tilde shortcut?

Hmm that would make sense but there is no keybind to that specific key. Might be some functionality associated with ¨ that is lost in translation.

shift + ¨ = ^ on my keyboard.

It's a shortcut: Alt+¨

Same here.

Hm it's also annoying that ~ is so difficult to type on Swedish and Italian keyboards.. It's shift-# for me, right next to the return key.