Linux Automatic Installer (ansible) thread

Hi! Just installed this on Ubuntu 20.04 with great results! Just wanted to say thank you for making this :heart_eyes:

1 Like

You're very welcome, thanks for giving it a go!

@igormpc as a follow up to my last message, you may realise I didn't get very far with the feedforward installation, something funky going on with the build dependencies that is beyond me so I've shelved it for the moment so I can pick lower hanging fruit -

1 Like

There are some new features in, notably support for installing the mutable instruments ugens -

I did a livestream last night to demo it (had a couple of hiccups, but I wouldn't expect anything less :slight_smile: )

1 Like

Hi all,
Apologies for being late to the party, but just confirming this is process is upgrading cleanly to tidal=1.7.10 and superdirt=1.7.3

If you've been dicking about with your configs, this is probably the command you want to run:

sudo ansible-playbook --connection=local -i localhost, --skip-tags "config"

Which will just update SuperDirt to the latest git tag (v1.7.3) and update tidal to the latest available from cabal (1.7.10) without touching any of the supercollider or editor configs.

Thread dig!

Pulsar editor support (fork/replacement of atom) has now been added :slight_smile:

1 Like

I've had the opportunity to give this some love the last few days - many updates!

  • After way too long, emacs support has now been added (it's just vanilla emacs, if you use doom or space and are interested in support, let me know)
  • I've rejigged the cabal process to be a bit more robust, in lieu of further major changes in that area
  • I've added support for @mindofmatthew 's excellent/experimental dedicated tidal (for now) editor,
  • I've added a remove playbook that nukes the tidal and supercollider user profile dirs for a clean slate
  • I've retired support for feedforward which is no longer being developed, nor installable without some jiggery-pokey
  • I've also moved distros that don't have cabal >= in their repos into a "legacy" group, who support a maximum tidal ver of 1.8.1

I think that's about it!


Thank you for providing this install option. One of my students did this (under WSL). At the command

sudo ansible-playbook --connection=local -i localhost,

this error appeared

TASK [roles/tidal : start xvfb service (debian)] 
fatal: [localhost]: FAILED! => {"changed": false, "msg": "Service is in unknown state", "status": {}}

I can only guess that xvfb is the virtual framebuffer device that you need when sclang is built and linked with QT support (which I always avoid, with cmake -DSC_QT=OFF .. supercollider/ at develop · supercollider/supercollider · GitHub )

I use Doom & would be interested.

1 Like

That's correct, by default I will use the distro packaged supercollider which does link the QT support, if there is a newer version of supercollider already installed then I usually just leave those steps out (iirc).

I assume the failure is because systemd under WSL is probably not running - I don't explicitly offer support for WSL, but it's certainly something I'll consider resolving.

Is your student running the packaged supercollider, or compiled from source?

then perhaps: Systemd support is now available in WSL! - Windows Command Line

(and using packaged supercollider, I assume)

1 Like
TASK [roles/neovim : install neovim editor and dependencies] **********************
fatal: [localhost]: FAILED! => {"changed": false, "msg": "No package matching 'neov
im' is available"}

Thanks for building this install pathway cleary

I managed to get most of the way except I think neovim ppa is no longer maintained?


Hey @glitchpop , thanks for the report - can you provide some extra details?

OS: (ubuntu/mint/debian etc)
Release: (22.04/21/11 etc)

I don't configure a ppa for neovim (you are welcome to), I just grab whichever apt gets by default ...

I already know the answer, but could you check:

apt-cache policy neovim

for me, and paste the output?

Thanks for the quick reply cleary.

Ubuntu Studio 22.04.3 LTS

apt-cache policy neovim returns:

Installed: (none)
Candidate: (none)
Version table:

Interesting - can you paste output of:

apt-cache policy

I suspect you don't have the universe repos enabled...

Package files:
100 /var/lib/dpkg/status
release a=now
500 /repositories/home:/aggraef:/purr-data-jgu/xUbuntu_22.04 - openSUSE Download Packages
release o=obs://,n=xUbuntu_22.04,l=home:aggraef:purr-data-jgu,c=
Pinned packages:

I also tried the Pulsar version, that worked but I've run into another problem. I had an old broken SC install which I thought I'd blown away but there seems to still be enough remnants on my system (no matter how much I purge remove). ansible-tidalcycles skipped the SC install which I assume is as a result of the old broken install. Might just be time to start from scratch with a fresh OS.

all of that is quite unexpected, it looks like you've removed all of the repositories from your system except for a suse repo (hosting obs maybe?)

Whatever the case, your system is in a very unusual state - a reinstall won't hurt, but if you want to try some stuff:

# re-add your ubuntu repos
sudo add-apt-repository "deb $(lsb_release -sc) main universe restricted multiverse"


sudo apt-get update

check neovim

apt-cache policy neovim

It skips when the version output by sclang -v is newer than what's available in the repos - so make sure the sclang (and associated sc binaries) have also been removed in your clean up

Thanks for your help. Yep, I had to remove some repos because they were no longer being maintained, which was breaking all updates. I find it very difficult to diagnose issues with broken parts of ubuntu, despite having come across these kinds issues fairly frequently over the years. cheers again. I'll let you know how I go.

This concisely explains why I keep the install process in ansible as close to vanilla as possible :wink:

If you are needing/wanting newer supercollider though, I've made a ppa for that:

1 Like

I blew it all away. Fresh Kubuntu install. Ran ansible. looks like it all worked.

Is there any documentation on running Tidal in Neovim? I can't seem to find much. Thanks.