SuperDirt not found

Hello everyone !
First post here :slight_smile:
I had a lot of issues installing Tidal Cycles, had some help by a friend who knows a bit about it. We tried a lot of things but still no chance...
Can I have some help with clean reinstalling ?
At the moment, when I type include("SuperDirt");
I get :

ERROR: Quark 'SuperDirt' not found
arg this =
arg this = nil
arg error =
arg this =
arg error =
arg this =
arg this =
arg name = "SuperDirt"
arg refspec = nil
arg url = nil
arg localPath = nil
var args = nil
arg this =
arg name = "SuperDirt"
arg refspec = nil
var path = nil
var quark = nil
arg this = "SuperDirt"
arg this =
var res = nil
var func =
var code = "include("SuperDirt");"
var doc = nil
var ideClass =
arg this =
^^ The preceding error dump is for ERROR: Quark 'SuperDirt' not found

Thank you very much, can't wait to try Tidal out !!


Hi Ozu,

Which operating system are you installing Tidal on? Windows, MacOS or Linux?


Hi James and thank you for your reply !
I'm using macOs Monterey.

Did you try running the automatic installation script suggested here?

That should install any components that are missing.

Yes, that's what I did in the first place. But it didn't work properly.

I might try again maybe ?

But my friend said that the problem was more that Supercollider couldn't find git if I remember correct.

So I ran the automatic installation script again, and now it looks like superdirt is up and running :slight_smile:
"SuperDirt: listening to Tidal on port 57120"
Then I followed the tutorial here.
But then on Atom when I do : TidalCycles -> Boot Tidal Cycles
I have an error in Atom :

Cannot browse tidal to obtain informations for autocomplete: Error: Command failed: echo ":browse Sound.Tidal.Context" | "/Users/tom/.ghcup/bin/ghci"
/bin/sh: /Users/tom/.ghcup/bin/ghci: No such file or directory
t> /bin/sh: /Users/tom/.ghcup/bin/ghci: No such file or directory

I bet i'm getting closer :)))
please help me !!

Hmm... it looks like the /Users/tom/.ghcup/bin/ghci file can't be found, which suggests Haskell hasn't been installed properly, or hasn't been installed in the expected location.

When you run the installation script in Terminal, are there any red errors or yellow warnings that appear relating to ghc?

Thank you very much for your reply James!
Here is what the command "ghci" gives :

edit : I installed xcode a few days ago, and maybe is this what fixed supercollider/superdirt

Quite possibly!

Xcode command line tools are required to install and run SuperDirt and GHCi. I'd try the solution suggested here - that should make sure the command line tools are installed, after which I'd try running the installation script again.

I will try, thank you very much !

And it wooooorks!!!!!
Thank you soooo much James <3 <3 <3
Now that Pandora's box is opened, where to start ? :thinking:


The “Learning Tidalcycles” course is a great place to start if you’ve not been through the material already: Weeks 1-4 - index

1 Like

I will, thank you!