Tidal on Raspberry Pi 4 with Ubuntu?

Hello!
I'm trying to install TidalCycles on a Raspberry Pi 4 with ubuntu 20. Supercollider works fine but when i run 'cabal install tidal' it installs but ends showing the message:

Warning: You asked to install executables, but there are no executables in
target: tidal. Perhaps you want to use --lib to install libraries instead.

And in emacs, it will show the following error when running a code like 'd1 $ s "bd"':

GHCi, version 8.8.3: https://www.haskell.org/ghc/ :? for help
Loaded package environment from /home/renzo/.ghc/aarch64-linux-8.8.3/environments/default
Prelude> syntax: :script
Prelude| Prelude|
:6:1: error: Variable not in scope: d1 :: t0 -> t

:6:6: error: Variable not in scope: s :: [Char] -> t0
Prelude>

Do you know how could I fix this? Thank you in advance!!

1 Like

I fixed it with

cabal v1-install tidal

Thank you!

Hi, I have a tool to simplify the installation of tidalcycles here:

I'd be very interested to know if it works on the raspberry pi if you would test it for me?

It should be a matter of running the following:

sudo apt install ansible git
git clone --recurse-submodules https://github.com/cleary/ansible-tidalcycles.git
cd ansible-tidalcycles/
sudo ansible-playbook --connection=local -i localhost, tidal.play.yml

Thanks!

Sure, I have another sd with the Raspberry Pi OS. Is it ok to test it there?

It looks like Raspberry Pi OS was previously Raspbian - I'm curious about that one as well, but I was specifically hoping you could test on the Pi w/ Ubuntu.

A way you could do it is to create a new user with a fresh home profile and run it there if you don't want to upset your current install?

Ok I will test it with both :slight_smile:

1 Like

I tested it on a fresh (updated) ubuntu sd. It installed everything ok and when I open SC it runs SuperDirt automatically. It doesn't install a text editor, right?

@cleary same thing with Raspberry Pi OS! :slight_smile:

This particular playbook doesn't (tidal.play.yml) - but you might want to try each of the editor playbooks (I'd be surprised if vscode and atom have pi builds, but the others should work):

# for tidalcycles + vscode
sudo ansible-playbook --connection=local -i localhost, tidal_vscode.play.yml

# for tidalcycles + atom
sudo ansible-playbook --connection=local -i localhost, tidal_atom.play.yml

# for tidalcycles + neovim - warning, it will clobber your init.vim (but take a backup)
sudo ansible-playbook --connection=local -i localhost, tidal_neovim.play.yml

# for tidalcycles + vim - warning, it will clobber your .vimrc (but take a backup)
sudo ansible-playbook --connection=local -i localhost, tidal_vim.play.yml

# for tidalcycles + feedforward - warning, this is extremely, extremely experimental
sudo ansible-playbook --connection=local -i localhost, tidal_feedforward.play.yml

awesome news, thanks again :slight_smile:

PS if your favourite editor isn't covered by one of these roles, I'll happily take requests (or even better, pull requests :stuck_out_tongue: )

Thank you! Sadly atom or vscode won't install on the raspberry pi. The only editor for tidalcycles that actually worked for me on the rpi is Emacs, but now I am practicing with vim :slight_smile:

I've been meaning to add an emacs role - watch this space :slight_smile:

1 Like

Well, it's not in their debian repository, but:
arm/pi build: https://aka.ms/linux-arm64-deb (linked from the main download page)

Can you let me know if it's usable? If it is, I'll add some consideration for it in my vscode role -

It works, but I had to install the 32bits .deb version. Then I installed the tidal package and it worked fine.

ok I'm not sure that makes sense, 32 bit in this sense is a reference to the 32bit x86 architecture which is distinct from the ARM architecture which I understand the pi uses...

I might leave it for now until I can understand it better for myself -

I am not really sure either, but it didn’t allow me to install the package from the link you sent me. I had to go to the downloads page and install this one

I forgot to say I did it on Raspberry Pi OS because I couldn’t get vnc working on ubuntu and didn’t have a screen with me. I think arm 64 does work with ubuntu, I will test it and let you know.

Ah, 32 bit ARM as opposed to 32 bit x86 - got it :wink:

... that's a bugger, it introduces a whole lot of conditions I'll have to test for and I'm not really sure I'm up for the challenge atm... one of the great things about 32 bit x86 is it's a dead duck these days :smiley:

I'll add it to the list of maybes though :slight_smile:

@cleary Yup, vscode worked on ubuntu with the arm64 version. Thanks for this tool, it’s really helpful :slight_smile:

Hey you're welcome, glad to see it's getting some use.

I've done an initial foray into managing custom stuff via the vars/all.yml file, so you can add a list of directories containing samples and that will be added to your supercollider startup, and any editor plugins that might use it (eg soundbrowsers in atom/vscode).

I've been thinking that it'd be nice to expand these customisations to include eg midi defs in sc, synthdefs (maybe by url, so you can just link to git content) etc.

I'd be curious to hear what would be useful to you -

I don't really know ansible, but I was wondering if it possible to translate the script in some way so that I can work on Windows.

MacOS has the easiest installation, with only one line to copy and paste on the terminal. With this ansible method, is now really easy for linux. But I think the automated version for windows still has some problems, right? I always use the manual installation and last weekend I did a free online workshop and one of the students had problems with the process on windows and I could only ask him to follow the class using the MiniTidal on Estuary, as I find it really hard to troubleshoot on an online environment.

Is it possible? Maybe on a long-term? Do you know if there is something similar, or if the "choco" version is working ok? I have another free workshop this weekend and I am pretty worried about how many people will tell me they had trouble installing on Windows.

The short answer is "probably" - I use ansible at work for desktop configuration (we run predominantly linux desktops), but my colleague has developed roles for our windows machines too, so we have a common SOE role which runs on both win and lin...

[edit] actually, it's a hard no - we're using a linux ansible controller to push the config to win clients:

Can Ansible run on Windows?
No, Ansible can only manage Windows hosts. Ansible cannot run on a Windows host natively
https://docs.ansible.com/ansible/latest/user_guide/windows_faq.html#can-ansible-run-on-windows

I recall seeing @yaxu mention this recently, I think it's received some love in the last week - I've never used it myself though.
[edit] found it:

Would a live booted usb/iso be of use to you as a fallback for these workshops?

1 Like