"Learning Tidal" course week zero - installation and exploration

We're not scheduled to start until 11th April, but as a lot of us are here a week early, lets try to make sure everyone has everything installed, and while we're at it, get to grips with the different parts of a tidal install and how they work together.

Installation instructions are here - have a go at the 'easy' installs first of all. If things don't work out-of-the-box, then feel free to create a new post in the Installation Help category on this forum.

I'm planning on making a quick video touring around the different parts of a tidal install, how it fits together, and explaining what can go wrong and how to fix it. Cheers!

7 Likes

Thank you! One small recommendation for the Windows install steps: you might want to add a change directory command before you create the temp folder, so it doesn’t get created in Windows/System32 and another step that deletes the temp folder afterwards.

1 Like

I’ve got it installed now on Windows 10 but I hit a couple of hold-ups on the way so I thought I’d note them here.

  1. Didn’t realise how much disk space it would need! (5GB+?) A note of this on the installation page would be handy. Thanks!

(I am a terminally disorganised person who always has “disk space low” warnings popping up. Yes, that is bad for my SSD and my soul and I should feel bad.)

  1. Original download of TidalCycles.1.4.3.nupkg using curl saved a redirect instead of the .nupkg file. Used https://packages.chocolatey.org/TidalCycles.1.4.3.nupkg instead (as linked to in redirect).

I think using curl -Lo instead of just -o should follow the redirect without manual intervention.

  1. I installed atom and the other packages and got an “apm not found” error on starting the TidalCycles install itself. Worked once I added the apm bin directory to the PATH environment variable and restarted PowerShell. That directory for me was
    %localappdata%\atom\app-1.45.0\resources\app\apm\bin
    (though I think you can’t use the %localappdata% shortcut in a Path variable - I can give more details if anyone else actually has this problem.)

Hopefully I just did something weird somewhere (like repeatedly running out of disk space during the install!) and nobody else will encounter the same problems. Looking forward to the club - thanks for running this!

1 Like

Thanks for the info! The windows choco install has deteriorated lately, since the chocolatey people rejected the package. I don’t usually use windows but hope to do find time to do some work on it soon.

Hey friends and nieghbors, I’m attempting a Win 10 install and I’ve run into a lot of issues, most of which I’ve been able to google fu my way through, but I seem to have reached the limit of my ability to problem solve, so I’m hoping I can get a little help.

I initially used the choco install method, and didn’t notice any errors, but upon attempting to load superdirt I got a class not defined error, tracked that down to super dirt not being installed, so I fixed that, and tried again, and got it to work (only after about an hour of figuring out that I needed to kill the previously running processes of sclang.exe before trying it again)

The next issue came when i got ATOM up and couldn’t locate the tidalcycles Package. That was a while ago now and I forget how I was able to get that squared away but it seemed to work as the package is there now. my new problem is when I boot the package I get this:

No configured ghc path
Ghci command: ghci
Ghc-pkg command: ghc-pkg
Load BootTidal.hs from C:\Users\PC1\.atom\packages\tidalcycles\lib\BootTidal.hs
t>


: error:
    Could not find module `Sound.Tidal.Context'
    It is not a module in the current program, or in any known package.

That sounded like tidal wasn’t installed so I did the manual install for both haskell and tidal, and I am able to load ghci in a PowerShell (admin) terminal, but when I type the import Sound.Tidal.Context command, I get the following error:
: error:
Could not find module `Sound.Tidal.Context’
It is not a module in the current program, or in any known package.
Which seems to indicate tidal is not installed, so in a new terminal I used the command:
cabal update
cabal new-install tidal --lib

and received this response:

PS C:\Windows\system32> cabal new-install tidal --lib

Warning: Unknown/unsupported 'ghc' version detected (Cabal 3.0.0.0 supports

'ghc' version < 8.10):

C:\ProgramData\chocolatey\lib\ghc\tools\ghc-8.10.1\bin\ghc.exe is version

8.10.1

Warning: Unknown/unsupported 'ghc' version detected (Cabal 3.0.0.0 supports

'ghc' version < 8.10):

C:\ProgramData\chocolatey\lib\ghc\tools\ghc-8.10.1\bin\ghc.exe is version

8.10.1

Resolving dependencies...

Up to date

(EDIT: I left out the part where if I try to import Sound.Tidal.Context it still acts like Tidal is not installed.)
Since I can’t figure this one out I think it’s time for me to ask for help. Let me know if you see something I should be doing differently.
Thanks,
Jesse Johannesen

Erp sorry it sounds like you’ve been on a bit of a mission!

My guess is that you’ve ended up with two copies of haskell installed, and that they’re confusing each other. Perhaps if you uninstall the one you’ve installed manually, that would help?

Upgrading the cabal package installer might also help, with cabal install Cabal.

Thanks Alex. After taking a look around, I discovered that the haskell platform wasn’t even a directory anywhere on my computer (not sure what happened) so I did a couple of wrong things before figuring out the right thing:

  • I installed the haskell platform from the installer on their site (most recent). Later I discovered this should have been version 8.4.3.

  • I spent a bunch of time trying to reinstall tidal and getting errors , with one of the packages failing with a WinGW issue. This was resolved completely when I installed Haskell 8.4.3 and re installed.

  • Atom gave me an error when booting the tidal cycles package, saying “The impossible has happened!” and referencing an error trying to “decompose ghci” from the previous Haskell install directory (the most recent release, which I had already previously uninstalled) this was resolved by locating that directory, (which still contained some files interesingly) and deleting it. Then rebooting the tidal package.

I have now been successful at getting audio response from the command:

`d1 $ sound “bd sd”

Whoo hoo!

Thanks Alex,
Jesse Johannesen

1 Like

Hi Fuzbox if you’re refering to the easy install it says, mkdir \temp
The \ will make the directory from root (so C: \temp).

1 Like

Hi @yaxu,

I use a MacBook Pro with Catalina 10.15.4 and I used the automated installation. Everything looked fine, but when I try to start SuperDirt inside a SuperCollider IDE with the given instructions, I get the following:

-> nil
ERROR: Class not defined.
in interpreted text
line 1 char 9:

SuperDirt.start

The alternative with a terminal window does not work either, here I got:
-bash: sclang: command not found
in response

What can I do?

Best Moritz

Hi @Moritz, it seems that SuperCollider has installed, but for some reason the SuperDirt ‘quark’ (a quark is supercollider speak for a plugin or add-on) hasn’t.

Try starting SuperCollider and then running include("SuperDirt"). It will take a while as it will also install Dirt-Samples which is a lot of sound samples. Once everything is installed you’ll need to ‘recompile class library’ from the menus (or just restart supercollider, as it always does this on start up). Then hopefully SuperDirt.start will work.

Great, thank @yaxu, it works! Indeed ‘quark’ was missing …

1 Like

Hi @yaxu,
do you have an introduction how to use Atom Editor for dummies or something similar?
I never used it before and I don't understand the instructions on the "_for_the_first_time" site at all. Fully lost :wink:

Thanks Moritz

ha, just found the flight manual - I'll start reading :slight_smile:

@moritz I also just put this video up Week 1 video 1 - Tidal interaction
If that doesn’t help, just comment there letting me know what’s unclear.

1 Like

I’ve had tidal installed for while and have been updating the main application with cabal but forgot to update SuperDirt until I read the update guide. “Quarks.update(“SuperDirt”)” didn’t seem to do much so I used the Language->Quarks->Check for Updates which got things up to date. The video on setting up Tidal was really useful and I’ve updated my Supercollider start-up script accordingly. Using the script I can now place my own samples in a separate folder. I was previously putting all of my samples in my Dirt-Samples directory. I don’t have many of my own samples yet, but imagine that once I get going, they’ll start to build up. I’d welcome any thoughts on how to keep them organised? By song/mood/type of sound? Any suggestions would be welcomed.

2 Likes

Is it possible to organize samples beyond the first level of the directory? I have a separate directory for my own samples, which can then be referred to by the name of the directory the samples are in. I’m not sure what happens if you have any directory hierarchy above that?

1 Like

No it’s not really possible. Because it’s come from live coding practice, tidal has put fast access over hierarchical organisation. You can have multiple sample libraries though, which is kind of adds one more level of organisation. I’ll go through loading additional libraries soon, probably in the next video, and share a pack of extra samples to load for the course.

1 Like

Thanks @yaxu. I can see how the need to type paths on the fly is at odds with a tiered file structure so will try and keep things organised spreading samples over a couple of folders. At the moment my startup file pulls in the standard superdirt samples along with a ‘sample’ folder in my home directory (which I keep backed up).

1 Like

4 posts were split to a new topic: Install problems

Hey Alex,

Thanks a lot for the course. I have actually wanted to learn tidal for a long time now, this seems a nice moment. I really like what is possible but I have always been stuck as the setup did not work for me. I hope I can finally get tidal run on my macbook.

I tried to follow the steps on easy install thing and then started atom and I get this message :

: error:
    Ambiguous module name ‘Sound.Tidal.Context’:
      it was found in multiple packages: tidal-1.4.7 tidal-1.4.7

Also
cabal install Cabal
returns command not found.

I would love to know what is causing this and How i can fix it :slight_smile:
TIA
Rohit